Elfutil version check (#558)
authorTim Haines <thaines.astro@gmail.com>
Thu, 7 Mar 2019 00:04:05 +0000 (18:04 -0600)
committerGitHub <noreply@github.com>
Thu, 7 Mar 2019 00:04:05 +0000 (18:04 -0600)
commit052b51da4040c4f1b7b5d91e23d437b5c5af1bd7
treef8d64ff28c74ddf87eb1b4525e2c0a6c84260f99
parent59fe914f4c8d548b079ca58ea324af9be8fe6716
Elfutil version check (#558)

* Add Ubuntu locations
* Search for libelf.so instead of libelf.so.1
    This makes the likelihood of find a symlink more probable.
* Add version checking
    find_package_handle_standard_args doesn't check versions of shared
    libraries, so we need to do it manually.
* Always make the configuration for elfutils noisy
cmake/Modules/FindLibElf.cmake